All systems are fully operational and latencies are back to normal.
Posted Oct 21, 2025 - 05:22 EDT
Monitoring
A fix has been implemented by our service provider, and we are monitoring the results.
Posted Oct 21, 2025 - 00:18 EDT
Update
Most Access functionality is back to being fully operational, but we are still seeing issues with live events, browser notifications and recorded video. We are closely monitoring our cloud providers for full resolution.
Posted Oct 20, 2025 - 20:47 EDT
Update
AWS has resolved the outage, and we are continuing to see services recover. One of our service providers is experiencing downstream effects from the outage, which may impact Brivo Access latency. We will provide another update when full functionality is restored.
Posted Oct 20, 2025 - 19:29 EDT
Update
Our cloud provider, AWS, is resolving their issue and we are seeing their services recover. As a result, we are seeing Brivo Access latencies coming down and our team is monitoring the situation closely. We will provide another update once full functionality is restored.
Posted Oct 20, 2025 - 16:19 EDT
Update
We are seeing continued issues with our public cloud provider. Resolving this issue is our top priority and we are monitoring AWS health continuously. We continue to take mitigating actions and will provide periodic updates.
We are aware that users are not able to load some Access pages and our engineering team is investigating. We continue to take mitigating actions and will provide periodic updates.
We are experiencing some additional intermittent service outages in core AWS services that underpin our access platforms. Users may still experience slowness with device status, notifications, and other pages. We continue to take mitigating actions and will provide periodic updates.
Brivo Access is still experiencing latency in regards to some of our 3rd party service providers. Users may still experience slowness with device status, notifications, and other pages. We continue to take mitigating actions and will provide periodic updates.
Posted Oct 20, 2025 - 10:59 EDT
Update
Dashboard metrics are recovering and we are seeing improved responsiveness from our 3rd party systems. Users may still experience slowness with device status, notifications, and other pages. We continue to take mitigating actions and will provide periodic updates.
Posted Oct 20, 2025 - 10:03 EDT
Update
We are still experiencing system delays which leads to dashboard statistics not populating with data. Users may still experience slowness with device status, notifications, and other pages. We continue to take mitigating actions and will provide periodic updates.
Posted Oct 20, 2025 - 09:17 EDT
Update
We are having continued system delays impacting overall system latency. Users may still experience slowness with device status, notifications, and other pages. We continue to take mitigating actions and will provide periodic updates.
Posted Oct 20, 2025 - 08:42 EDT
Update
We are seeing improved performance with Brivo Access. Users may still experience slowness with device status, notifications, and other pages. We continue to take mitigating actions and will provide periodic updates.
Posted Oct 20, 2025 - 07:57 EDT
Identified
We are currently working on resolving issues with Brivo Access, related to an overall AWS outage. Users may experience latency or difficulty using Brivo Access at this time. We are taking mitigating actions and will continue to provide updates.